Install it on LINUX UBUNTU

Discuss Chaos Strikes Back for Windows and Linux, an unofficial port of Chaos Strikes Back to PC by Paul Stevens, as well as CSBuild, an associated dungeon editor.

Moderator: Zyx

Forum rules
Please read the Forum rules and policies before posting.
Post Reply
Pietrus
Novice
Posts: 13
Joined: 1-Jun-10 13:53

Install it on LINUX UBUNTU

Post by Pietrus » 7-Jun-10 06:58

I don't manage to install it on ubuntu

Could you explain me how to do that ?

Thx

Pietrus

Pietrus
Novice
Posts: 13
Joined: 1-Jun-10 13:53

Re: Install it on LINUX UBUNTU

Post by Pietrus » 7-Jun-10 07:57

which is the better way to play CSB for win and linux ?
Windows or Linux,

the linux version have a greater number than the windows version,

it seems to say than this is a better one ?

User avatar
beowuuf
Archmastiff
Posts: 20660
Joined: 16-Sep-00 12:00
Location: Basingstoke, UK

Re: Install it on LINUX UBUNTU

Post by beowuuf » 7-Jun-10 08:46

The windows version is the most current

Pietrus
Novice
Posts: 13
Joined: 1-Jun-10 13:53

Re: Install it on LINUX UBUNTU

Post by Pietrus » 7-Jun-10 08:46

on that page :

http://dmweb.free.fr/?q=node/851#toc19

there is two version of DM/CSB for Linux :

Clone-CSBwin-Linux100.tar.gz
CSBwin v10.0 for Linux with the original Dungeon Master and Chaos Strikes Back dungeons.


and :

Clone-CSBwin-Linux11_014.zip Clone-CSBwin-Linux11_014.zip
CSBwin v11.014 for Linux

I don't understand the interest of keeping V10.0 if V11.014 existing ?

I would like to play DM and late CSB with the same characters -

which version need I to download ? v10 or v11 ?

thx

Pietrus
Novice
Posts: 13
Joined: 1-Jun-10 13:53

Re: Install it on LINUX UBUNTU

Post by Pietrus » 7-Jun-10 09:21

windows version the most current ? strange for a gnu software no ?
is the project always alive ?

thx

other question :

is "Dungeon Strikes Back" a Gnu RTC project ?

User avatar
beowuuf
Archmastiff
Posts: 20660
Joined: 16-Sep-00 12:00
Location: Basingstoke, UK

Re: Install it on LINUX UBUNTU

Post by beowuuf » 7-Jun-10 10:58

Version 10.0 was last guaranteed stable release that would work with all existing custom dungeon. There have been further engine versions released with advanced functions for individual dungeon. As far as I understand, you need to 10.0 package for all the dungeons, etc, and it is up to you if you wish to upgrade to the 'stable beta' of 11.4.

The software is a personal project of Paul Stevens. He's released the source code for people to look at, and welcomes people tinkering to improve things, but it is not GNU. The base files (dungeons and graphics) and IP are still the property of FTL, and this fan project exists and is destributed only because of their gracious attitude.

The project is 'alive' in that Paul occasioanally will do things if someone has a project that he can aid with, but the engine does all that it needs to so is essentially finished.


I will leave Sophia to answer the other question where you asked it, but I assume it is the same as above.

Pietrus
Novice
Posts: 13
Joined: 1-Jun-10 13:53

Re: Install it on LINUX UBUNTU

Post by Pietrus » 7-Jun-10 12:34

very thx,

but there is two location to download it :

here :
http://dmweb.free.fr/?q=node/851#toc19

and :
http://www.dungeon-master.com/forum/vie ... 46&t=23210

wich is the good one ?

User avatar
Paul Stevens
CSBwin Guru
Posts: 4100
Joined: 8-Apr-01 16:00
Location: Madison, Wisconsin, USA

Re: Install it on LINUX UBUNTU

Post by Paul Stevens » 7-Jun-10 13:57

For playing DM and CSB-----any of those
releases is the "Good One". I have no idea
why we have both the 10.0 and the 11.014
versions foir Linux---I do not maintain the
Linux versions. Perhaps they use different
graphics libraries or something. But I
believe that either will work just fine for
DM and CSB.

More recent versions have fixed one or two
minor bugs and expanded the engine for
ConfluxIII. If you want the most recent
Windows version you can get it at:
http://dianneandpaul.net/CSBwin
11.031 appears to be most recent.
You will have to copy the newest engine
executable into your DM or CSB folder.

If you want more recent Linux versions,
you will have to ask me for the source
code and do it yourself.

User avatar
MasterWuuf
Ee Master
Posts: 736
Joined: 11-Sep-08 19:22
Location: Way Down Here, Louisiana

Re: Install it on LINUX UBUNTU

Post by MasterWuuf » 25-Feb-11 17:49

I can't figure out how to download, unzip and install DM on Linux either.
I looked through this thread but really didn't notice any
1. Do this
2. Do this
3. Do this
4. Wah lah! (never tried spelling that before, so it's probably wrong)

Anyway, I downloaded it and think I managed to unzip it, but it doesn't do anything on Linux or Windows.
Any chance someone could try the 1,2,3, Wah lah (not Muahah) help for me?
"With a timid smile, MW withdraws his latest avatar"

User avatar
Sophia
Concise and Honest
Posts: 4002
Joined: 12-Sep-02 19:50
Location: Nowhere in particular
Contact:

Re: Install it on LINUX UBUNTU

Post by Sophia » 25-Feb-11 19:18

MasterWuuf wrote:Wah lah!
Voila.

That's about all of use I can offer in this thread. ;)

User avatar
MasterWuuf
Ee Master
Posts: 736
Joined: 11-Sep-08 19:22
Location: Way Down Here, Louisiana

Re: Install it on LINUX UBUNTU

Post by MasterWuuf » 25-Feb-11 22:43

Sophia wrote:
MasterWuuf wrote:Wah lah!
Voila.

That's about all of use I can offer in this thread. ;)
Thanks Sophia. It was a help, although I'm still hoping to get some help with running DM on Linux.
"With a timid smile, MW withdraws his latest avatar"

User avatar
Sphenx
Lo Master
Posts: 400
Joined: 9-Sep-01 09:23
Contact:

Re: Install it on LINUX UBUNTU

Post by Sphenx » 26-Feb-11 09:11

MasterWuuf wrote:
Sophia wrote:
MasterWuuf wrote:Wah lah!
Voila.

That's about all of use I can offer in this thread. ;)
Thanks Sophia. It was a help, although I'm still hoping to get some help with running DM on Linux.
"Voilà" is even better.

Now for the ubuntu install.

First on DME, CSBWin v10.0 contains the whole package while CSBWin v11.014 contains only the binary.
So you still need to download 10.0 at least.

I tried to run it on a fresh Ubuntu 9.10.
It tells me I am missing libHermes. I can't find it easily on the web (there are some empty places?) so I am trying to recompile CSBWin from the sources to see if I can run it.

I will post more later.
MasterWuuf wrote:Anyway, I downloaded it and think I managed to unzip it, but it doesn't do anything on Linux or Windows.
We'll just try to run CSBWin for linux on a linux system, ok? :roll:

User avatar
MasterWuuf
Ee Master
Posts: 736
Joined: 11-Sep-08 19:22
Location: Way Down Here, Louisiana

Re: Install it on LINUX UBUNTU

Post by MasterWuuf » 26-Feb-11 13:23

You're kidding, right? Of course, I tried to run it on Linux Ubuntu. :roll:
It didn't work. That's why I asked for help. :?
"With a timid smile, MW withdraws his latest avatar"

User avatar
Sphenx
Lo Master
Posts: 400
Joined: 9-Sep-01 09:23
Contact:

Re: Install it on LINUX UBUNTU

Post by Sphenx » 26-Feb-11 21:55

Hey, Pietrus and MasterWuuf, here is what worked for me:

1) Download Clone-CSBwin-Linux100.tar.gz
2) Download Clone-CSBwin-Linux11_014.zip
3) Unzip Clone-CSBwin-Linux100.tar.gz; this should give you a chaos_strikes_back_100 directory

At this point, you would run CSBlinux.sh or DMlinux.sh but it didn't work for me, program complaining about libHermes missing (which I didn't find).

4) Unzip Clone-CSBwin-Linux11_014.zip; this will give you an executable file named CsbWin.
5) Move this CsbWin as .Chaos_strikes_back_for_linux into chaos_strikes_back_100 dir.

Then run CSBlinux.sh.
It fixed the libHermes problem in my case and started the game.
However I did not have sound.

Could you try that and tell if you get something?

User avatar
Sphenx
Lo Master
Posts: 400
Joined: 9-Sep-01 09:23
Contact:

Re: Install it on LINUX UBUNTU

Post by Sphenx » 16-Mar-11 07:09

Has anyone tried to run CSBWin under linux since?

It appears that the savegame loading seems broken.
I always get a Segmentation fault when I click "Resume" button. Either DMlinux or CSBlinux.

Is there any version superior to 11.014 compiled for linux? Or I would have to try compile the latest version myself and see if the problem's still here.

Guignol
Neophyte
Posts: 1
Joined: 23-Jul-11 17:42

Re: Install it on LINUX UBUNTU

Post by Guignol » 23-Jul-11 18:10

First, I am a linux newb, please be kind. :)

CSBwin runs very nicely on my windows computer at home. Now at my parent's place we have a linux ubuntu comp, and here the problem begins.
1. Tried install v10, didn't work at all.
2. Found this thread, did the procedure propose by Sphenx (thanks!), and also changed the 11.04 binary properties to make this file an executable program, and DM launched well.
Now the problem is:
- I can save a game once. But once there is a saved game file in the DM directory, if I try to save a game again the program fails.
- If I click "resume" the program fails.
It seems all game redaing and writing functions fail once there is already a saved game in the saving directory.

I tried to search other threads on this forum but it seems everybody else went over this problem easily and focus is on sound issues. In this thread for example: Porting/updating CSBwin for Linux and sound support.
So it seems this issue as been solved already, can someone be so kind as to tell the newbs how to do?

Thanks!

User avatar
Sphenx
Lo Master
Posts: 400
Joined: 9-Sep-01 09:23
Contact:

Re: Install it on LINUX UBUNTU

Post by Sphenx » 25-Jul-11 21:05

Guignol wrote:First, I am a linux newb, please be kind. :)
We always are :)
Guignol wrote: I tried to search other threads on this forum but it seems everybody else went over this problem easily and focus is on sound issues. In this thread for example: Porting/updating CSBwin for Linux and sound support.
So it seems this issue as been solved already, can someone be so kind as to tell the newbs how to do?
There I would like to know as well. The resume/save failed for me too.

Where are our linux users? :?:

Christoph
Craftsman
Posts: 102
Joined: 19-Nov-11 23:04

Re: Install it on LINUX UBUNTU

Post by Christoph » 20-Nov-11 17:08

Hallo,

resuming and saving fails; youn can save exactly once (as long as no save file is already present), and you cannot load from the saved file. This happens consistently (at least on modern Linux installations).

Therefore I tried to compile the current version 11.067, but after fixing some minor bugs (found 2 Microsoft specific data types and flaws in the build system / documentation), I'm stuck at the linker stage. It won't build an executable programm, see the other Linux thread on the CSBWin board here.

Christoph
Christoph

User avatar
Gandalf
Novice
Posts: 18
Joined: 15-Sep-10 09:47

Re: Install it on LINUX UBUNTU

Post by Gandalf » 18-Jul-12 12:01

Hi guys Thank you very much for your hard work ( Paul, Christoph, Ful Ir ...and all others :twisted: )

I was able to launch the latest executable from Ubuntu Lynx 10.04 ARM 64 bits but when I try my own build from sources the program starts but I've got a segmentation fault when graphics.dat is loaded.

Any tips ?

I saw your latests dev with 12_3 sources and the thread about GTK+ or SDL conversion ... I cross my fingers for the next version :wink:
Dungeon MaSTer since 1987 , DMJava & RTC Designer from these glorious days ;-)

User avatar
Paul Stevens
CSBwin Guru
Posts: 4100
Joined: 8-Apr-01 16:00
Location: Madison, Wisconsin, USA

Re: Install it on LINUX UBUNTU

Post by Paul Stevens » 18-Jul-12 16:41

Ubuntu Lynx 10.04 ARM 64 bits
What did you say? That CSBwin was able to run
on a 64-bit ARM architecture? If this is true,
who can we find to support such a thing?

I went back and studied the previous posts in
this thread but I understand very little of what
was said.

Who is actually working on a native Linux version
or is able and willing to spend the time and
resources to produce a relatively 'clean' source
code. I am willing to make the effort but I am
very ignorant of Linux issues. I could probably
get it to work on one particular distribution but
it would not be pretty. Getting it to work
natively on a 64-bit architecture seem to me to
be nigh impossible. But I've learned new things
before.

User avatar
Gandalf
Novice
Posts: 18
Joined: 15-Sep-10 09:47

Re: Install it on LINUX UBUNTU

Post by Gandalf » 18-Jul-12 18:03

I guess it works with runtime libraries for the i386 architecture, configured for use on an amd64 or ia64 Debian system running
a 64-bit kernel.

My test was done on AMD athlon 64 X2 Dual Core 4600+ with 3 Go and Linux Kernel 2.6.32-41 ( uname -m
returns x86_64 and I try uname -a to be sure.. ;-) )


I can beta-test any version but my linux and programming skills are very low ( till I learned some basics & 6502 ASM in my early years...)

I was able to run CSB CsbWinLinuxBin11_014.7z ( an old version by unknow according to latest changelog ). I was able to move in prison area and save my four heroes but resume was not working ...

Hint/Utility detects the sav file as corrupted but with another sav file ( from windows game ) it was working fine, at least the current working directory was the good one and the tool can check and detect save2 3 or 4. I've got no sound so far but it is a minor thing I guess It is linked to the ALSA/Pulse audio mess... ( I will try the pulse patch later ... )

GTK 1.2 was a bit tricky to force via
sudo add-apt-repository ppa:adamkoczur/gtk1.2 && sudo apt-get update
sudo apt-get install libgtk1.2

Lucid uses the newer libgtk2. Just did a google search (https://bugs.launchpad.net/ubuntu/+s....2/+bug/478219) and found a PPA that has lucid gtk+1.2 binaries: https://launchpad.net/~adamkoczur/+archive/gtk1.2

To install:

Code: Select all

sudo apt-add-repository ppa:adamkoczur/gtk1.2
sudo apt-get update
sudo apt-get install gtk+1.2
( from http://ubuntuforums.org/showthread.php?t=1784254 )



To compile I add/check these lines :
sudo apt-get install libgtk1.2-common
sudo apt-get install libgtk1.2dbl
sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-sdl dpkg-dev
[Christoph] 111206
Version 12.100v0 corrects hint oracle bug:
Earlier versions crashed, if too many "hint items" were present.
Only "src/Hint.cpp", version numbering and documentation changed.
[Christoph] 111122-111127
New version is 12.0; updated from Windows version 11.067,
minor changes to make it compile on Linux (x86) out of
the box again.
Hermes not included, because detection fails for me.
Sound is half-broken, as well as window-resize.
[Maciej] 110805 .deb package: 110902
Version 11.059 (armel for Nokia N900)
[Philipp] 110327?
Version 11.059 (armel for Pandora)
[?] 090424?
Version 11.014 (x68)
[?] ?
Version 10.0 (x68)
(changeLog)

WE need an ARCHLINUXMASTER for the next step... Christoph perhaps ? ;-)
Dungeon MaSTer since 1987 , DMJava & RTC Designer from these glorious days ;-)

Christoph
Craftsman
Posts: 102
Joined: 19-Nov-11 23:04

Re: Install it on LINUX UBUNTU

Post by Christoph » 14-Oct-12 05:32

I'm not an archlinuxmaster, but also failed to get a native 64 bit version compiled. According to Paul this is due to the "de-facto Atari emulator" (simplified).

I have, however, working source code, build-, installation-, and run-scripts for i386, unfortunately requiring Esound. My current version is 12.3v1.

The current one has overlays and Pulseaudio support.
Christoph

Post Reply