splicing logs

Discuss Chaos Strikes Back for Windows and Linux, an unofficial port of Chaos Strikes Back to PC by Paul Stevens, as well as CSBuild, an associated dungeon editor.

Moderator: Zyx

Forum rules
Please read the Forum rules and policies before posting.
Post Reply
Posts: 207
Joined: 11-Oct-11 05:32

splicing logs

Post by Phoenix » 13-Sep-18 20:22

I can't seem to be able to splice logs to form a workable playfile. Here's what I've tried:

1) Start dungeon and play.
2) Save and quit.
3) Restart game.
4) Play then save and quit.
5) spliceCSB24.exe record00001.log
6) move playfile.log to csbwin directory
7) start playback.

Every single time I get a sequence/timing error; recorded with a different dungeon file, and when I quit, system error 0x0007dbc systemError.

What am I doing wrong?

User avatar
Paul Stevens
CSBwin Guru
Posts: 4100
Joined: 8-Apr-01 16:00
Location: Madison, Wisconsin, USA

Re: splicing logs

Post by Paul Stevens » 20-Sep-18 17:32

I don't know what you are doing wrong. I just tried the following:

1) Remove all recordnnn.log files
2) Start CSBwin. Misc/Record. Play.
3) Save and quit. record00000.log appeared.
4) Start CSBwin. Misc/Record. Restore saved game and play.
5) Save and quit. record00001.log appeared.
6) Copy SpliceCSB24.exe to game folder.
7) Remove old playfile.log (important)
8 ) Drag record00001.log onto SpliceCSB24.exe. Press 'Enter' when it is done.
9) A new 'playfile.log appeared.
10) Start CSBwin. Misc/Playback.
11) It all worked well.

Notice that I did not have to move 'playfile.log' as you said
you did in step 6). I don't understand why you had to do that.

I was using CSB Windows 10 version 16.

If you cannot get this to work, we can arrange for you to
ship your entire game folder to me for analysis.

Posts: 207
Joined: 11-Oct-11 05:32

Re: splicing logs

Post by Phoenix » 25-Sep-18 17:30

Conflux stores logs in its own directory instead of the main game directory. I was calling spliceCSB24 from a Uwin environment(ksh in a dosbox). There was definitely something wrong because the playfile.log started with a savegame load instead of the normal game start. I rebooted my machine, and I can't reproduce the error. The drag and drop method worked first time.

Post Reply